Back to overview
Degraded
Email Delivery Delays of Some Emails
Jul 02 at 11:16pm JST
Affected services
jicoo.com
Resolved
Jul 02 at 11:32pm JST
Problem has been solved.
Affected services
jicoo.com
Created
Jul 02 at 11:16pm JST
Our engineering team is actively working to identify the root cause and implement a solution as quickly as possible. We will provide updates as soon as we have more information.
Affected services
jicoo.com